image description


Quicktime X Stuttering Audio Problem
  Forum Index » StudioLive General Discussion 
Author
Message
markusgalla
Presonic

Joined: 22/01/2012 15:33:29
Messages: 151
Location: Germany
Offline

Hi,

there is a huge problem with FireWire Audio Interfaces and the Quicktime X component of Mac OS (Maverick). Apple Support says that this is not an Apple problem and driver related. There are many long, long discussions on the support forum's board about this issue.
You can follow one of these here:

https://discussions.apple.com/thread/5470956?start=0&tstart=0

There are even more discussions for specific FireWire hardware. I read that Focusrite already addressed this issue and that they are working on a solution. I have the same problem with my StudioLive 16.0.2. The drivers haven't been updated quite some time now. Is there anything in the making? Would be good to hear that PreSonus is working on a fix, because Apple won't do so. The only solution so far is to switch Latency in Universal Control to Safe Mode 1 or 2. This affects Soundcloud as well as every player that uses the Quicktime X browser component. It happens in Safari, Firefox, Chrome.....

This message was edited 1 time. Last update was at 14/05/2014 10:10:25

Music - that's it!
markusgalla
Presonic

Joined: 22/01/2012 15:33:29
Messages: 151
Location: Germany
Offline

Nobody with contact to a PreSonus rep who knows anything about a work in progress to fix this?
Music - that's it!
fcapolongo
Prenoob

Joined: 30/09/2013 20:24:59
Messages: 15
Offline

I’ve had the same problem since upgrading to Mavericks. When playing MP3s with QT player it produces a constant crackle. I can use iTunes to play MP3’s without a problem. It only happens when using the QT Player. This is through my 16.0.2 with most current drivers.
FinalSaga
Presonic
[Avatar]

Joined: 29/07/2012 06:08:06
Messages: 308
Location: Denmark
Offline

Hey guys

Apple has been a bit. .. absence when it comes to updates to their FW drivers with updates
If you read other threads on this.. You will find the same thing
So it's kind of a 'no idea whats next' from Presonus since yeah....
Apple does'nt give 'heads up' any more and just goes ahead heheh

That is not a presonus thingie, that's apple changing without notice :/
It's been like this for a while now
To foresee what they're doing and thinking is kind of inpossible

Ch33rs
Saga

This message was edited 1 time. Last update was at 26/05/2014 00:11:15

markusgalla
Presonic

Joined: 22/01/2012 15:33:29
Messages: 151
Location: Germany
Offline

I don't think that the blame is on Apple. This bug exists for two years, now. It was there before Maverick. It all started with the version before. I think this is enough time for third party manufacturers to adjust and update. Focusrite did. As far as I know Universal Audio did, too. RME did, too. Where is PreSonus? Apple always said that there will be adjustments in order to maintain compatibility with thunderbolt. It is good, that Firewire remained as part of some computers along Thunderbolt. And how old is Thunderbolt? Apple started to deliver the first Macbooks with Thunderbolt in February 2011! That's more than 3 years now and there even is a second Thunderbolt generation and a third to come. Where's PreSonus? I do not want to put the blame entirely on PreSonus. I do not ask for newest drivers or firmware update right at the start of something new or when Apple decides to change anything. But two years should be enough to address this bug and three years of Thunderbolt should be enough to implement this into their products or at least make things compatible and work. Even Windows can make use of Thunderbolt since 2012.
Music - that's it!
gkmachine
Prenoob

Joined: 17/04/2013 13:32:49
Messages: 6
Offline

Just want to add my bit to this.

I too use one Mac with StudioLIve 16.0.2.....audio crackles stutters on Safari on soundcloud and so on as well as some non-public DJ download sites I use.

I use another Mac with a Focusrite Saffire Pro 14.....audio DID stutter on this too until I updated my drivers. Now it's fine.

I guess not enough people are using the 16.0.2 (or other presonus mixers) compared to little audio interfaces that thousands of home-users use making the upgrade maybe not worth their while (until enough people complain hard enough).

UPDATE: PLEASE NOTE

I emailed Presonus about this and here is their answer:

"The issue with the stuttering problem has to do with an issue of Quicktime and playback through firewire. We have opened a case with Apple at this time and they have acknowledge that there is a problem with firewire audio on their application.

At this time, other companies have created "work arounds" for problems dealing with the problem Apple notes is an issue. As our devices communicate directly on the kernel for access to the core audio stream, there is an issue with the sandbox Quicktime application and an error in the code that only effect firewire devices, mainly our older StudioLive mixers, like the one you have.

Note that this is only a problem with Quicktime and iTunes 11. No prior versions of Quicktime have this issue and we have convfirmed that the issue happens with all releases of Mavericks and Mountain Lion, or any other prior version of OSX running QT or iTunes 11.

Presonus Audio software engineers are possibly looking into a way to correct the problem if Apple does not correct the problem and we will look into seeing if it is possible to correct in our driver design. Again, thank you for your consideration and please let me know if you have any more questions."

This message was edited 1 time. Last update was at 05/08/2014 21:20:49

 
Forum Index » StudioLive General Discussion
Go to: