image description


Studio One 2.5.1 now available!
  Forum Index » Studio One General Discussion 
Author
Message
Ari Ahrendt
Presonic
[Avatar]

Joined: 19/02/2012 18:00:32
Messages: 106
Offline

Hello Studio One Users,

The maintenance update Studio One 2.5.1 is online!
For detailed list of enhancements and fixes please read the release notes.

Have fun with the new Studio One 2.5.1!
best regards
Ari




---------------------------------------------
Studio One 2.5.1 Release Notes
=========================


This is a maintenance update which includes several quality and stability improvements, as well as a few feature enhancements.

PLEASE NOTE BEFORE UPDATING: As part of this release all dynamics plug-ins have been updated to address an issue introduced in version 2.5 which caused audible artifacts when using the "Auto" or "Adaptive" modes. As a side effect of this fix, affected channels may have a higher output volume compared to version 2.5. Expect having to adjust mix settings after updating to 2.5.1. The following plug-ins are affected:

- Compressor with envelope on auto or adaptive
- Tricomp with envelope on auto
- Multiband Dynamics with envelope on auto
- Autofilter with envelope on auto
- Dynamics section in Channelstrip

If you're in doubt which songs might be affected, please make sure to create mixdowns before updating to 2.5.1.



Studio One 2.5.1 has the following enhancements:

- Support for Japanese characters in Project export (toggled via program language)
- Muted tracks can be enabled now in stem export
- [Sample One] loop mode added
- Mixdown of soloed track is placed under soloed track
- Added manual addendum for German, Spanish, French and Japanese


Studio One 2.5.1 fixes the following issues:

- "Disk is not fast enough" message displayed when audio device sync error occurs while recording
- CD cannot be written when 1st pause is longer than 2 seconds
- [OSX] Enter key not working in song notes
- [OSX] Plugin GUI fix or UAD and D16 VST plugins
- [OSX] Audio folder no longer displayed as Volume in file browser (paths used from this volume need to be recreated)
- Crash after renaming songs
- New Song template tab not remembered
- Drawing bug with layer events
- MIDI file import bug when notes have overlap
- Automation points not added when using "Insert Silence"
- Explode pitches does place new tracks outside of folder
- Zoom to selection not working correctly with folder events
- Track navigation bug when traversing tracks in open folders
- Fixed volume meter curve in Transport and Track meters
- Using mute tool on automation can crash
- Inserts lost when transforming back an old 2.0 song
- Error when using "Duplicate and Insert" repeatedly
- Reverse audio does not use original event color
- Several Sampler engine issues (improved sfz import; clicks at sample end)
- Groove quantize bend marker problem
- I/O settings can't be correctly restored (for example: StudioLive Outputs in template on OSX)
- Plugin name filter fixed (East West "Play" name not displayed correctly)
- [ProEQ] Oversampling now disabled when no band active
- Dynamics plug-ins have a fixed Adaptive and Auto mode (2.5.0 songs may sound louder if these modes were enabled – please read IMPORTANT NOTE above)
- [Ampire] Mid and Treble controls are reset when set to minimum
- [Open AIR] Dry signal latency compensation not working on uneven buffer-sizes
- [Sample One] Parameters not correctly updated after loading Preset
- [Impact] Improved default preset and Amp envelope

This message was edited 2 times. Last update was at 05/09/2013 11:31:28

Ari Ahrendt / Quality Assurance / PreSonus Software Ltd.
http://studioone.presonus.com

www.denoisary.de @ www.arimusik.de
mech2161
Presonic
[Avatar]

Joined: 11/06/2012 17:51:02
Messages: 756
Location: Morgantown WV
Offline

Thanks guys! This came along pretty quick.
Kevin
il_trulli
Prenoob
[Avatar]

Joined: 09/01/2013 00:46:22
Messages: 4
Location: Milano, Italy
Offline

Just updated, tonight I'm gonna try it and see if the dropout message is showing again! Hope it works
Thanks a lot!
Presonus Audiobox 1818 VSL
Focusrite Octopre LE
Studio One 2.5 Professional
Windows 7 on HP Pavilion dv6-6169sl
[WWW]
Daw stew
Presonic
[Avatar]

Joined: 11/10/2012 14:04:16
Messages: 957
Offline

Great work guys
Windows 7 x64
Core2Duo E4300 Cpu
4gb DDR2 RAM
ASUS P5B-E motherboard
Nvidia graphics card
dcarlton
Prenoob
[Avatar]

Joined: 19/01/2012 19:56:33
Messages: 28
Location: Ontario, Canada
Offline

Looking great thus far, not seeing the odd clicking behavior in Open Air anymore.
When I let go of what I am, I become what I might be.
-
S1v2 Pro, Windows 8 x64, i5-2500K, 16GB, 3.5TB, nvidia GTX550Ti 1MB, Dell 23" LCD, Edirol UA-25EX, Novation 25SL mkII, Virus TI Snow, Akai APC-40, beyerdynamics DT-770 Pro, macbook late 2008 unibody
crushed
Prenoob
[Avatar]

Joined: 07/10/2010 11:43:31
Messages: 30
Location: Israel
Offline

This is the old version installer!!! 2.5.0... Where is the new one??????
bug.png
[Thumb - bug.png]
 Description [Disk] Download
 Filesize 10 Kbytes
 Downloaded:  23199 time(s)

This message was edited 2 times. Last update was at 25/02/2013 18:47:34

Presonus Studio One 2.6
ADAM A5 Monitors
Presonus Audiobox 22VSL
Fender American Standart Telecaster

https://soundcloud.com/denisvmedvedev
[WWW]
CPhoenix
Presonoid

Joined: 13/03/2011 00:11:38
Messages: 1993
Location: North Jersey
Offline

Ari Ahrendt wrote:- [Sample One] loop mode added


I've been WAITING FOR THIS! Glad you guys caught it even though I never sent in a feature request. This should make SampleOne much more usable for me. Thank you.


- New Song template tab not remembered


same as above! i hope this works well.. it'll be nice to open up straight to a new song again w/ my default template ready to rock. having this feature + an SSD system drive practically gives you a hardware feel!


- Inserts lost when transforming back an old 2.0 song


nice fix. i hope the people who were complaining about this before stop by and say thank you for fixing this issue. this was a big booboo.. nice that it got sorted out

This message was edited 1 time. Last update was at 25/02/2013 18:57:28

Win 8.1 x64 // i7 3930K (@ 4.2GHz) // Samsung Pro 512GB // 500GB SSD (via Raid 0) // 2TB HD // 32GB RAM // Antec Kuhler 620 // Radeon HD 7870 + Radeon 5450 // MSI X79a GD45 Plus mobo// TI chipset Firewire card

DAW(s): Studio One v2.6 // Maschine Studio // Reason 7 via Rewire
Plugs: UAD 2 Quad, Softube CL 1b, Klanghelm, Toneboosters, Soundtoys, Slate VTM, Kramer Tape
Instr.: Addictive Drums, Gladiator2, Sylenth, AAS Bundle, K9U, IK Total Studio 3, Cinesamples, RealGuitar/Strat/LPC, Trilian

RME UCX // AKG c214 // SM57 + Cloudlifter CL1 // JBL LSR 4328p // FMR RNLA // Korg Kaossilator Pro // Novation 61 SL MKii // Korg MicroKey 25 // Presonus Faderport // Contour Designs Shuttle Pro

Next up: Motif XS rack
[WWW]
CPhoenix
Presonoid

Joined: 13/03/2011 00:11:38
Messages: 1993
Location: North Jersey
Offline

I was PRAYING full Mackie HUI support was gonna be included in this update so I could pull the trigger on an MCU.

But... i'll be patient and hope it's in a 2.6 release
Win 8.1 x64 // i7 3930K (@ 4.2GHz) // Samsung Pro 512GB // 500GB SSD (via Raid 0) // 2TB HD // 32GB RAM // Antec Kuhler 620 // Radeon HD 7870 + Radeon 5450 // MSI X79a GD45 Plus mobo// TI chipset Firewire card

DAW(s): Studio One v2.6 // Maschine Studio // Reason 7 via Rewire
Plugs: UAD 2 Quad, Softube CL 1b, Klanghelm, Toneboosters, Soundtoys, Slate VTM, Kramer Tape
Instr.: Addictive Drums, Gladiator2, Sylenth, AAS Bundle, K9U, IK Total Studio 3, Cinesamples, RealGuitar/Strat/LPC, Trilian

RME UCX // AKG c214 // SM57 + Cloudlifter CL1 // JBL LSR 4328p // FMR RNLA // Korg Kaossilator Pro // Novation 61 SL MKii // Korg MicroKey 25 // Presonus Faderport // Contour Designs Shuttle Pro

Next up: Motif XS rack
[WWW]
jpettit
Presonoid
[Avatar]

Joined: 13/01/2011 23:44:45
Messages: 2211
Location: Portland Oregon
Offline

FYI
This is by far the easiest way to update your software.
Just run S1 then select "Check for Updates" form he help menu.
S1 does everything for you after that.

My Website
FRs: Tempo Detection & Mapping
Training Videos: Advance Melodyne, Creating Macros, 2.5 New Features, Signal Flow, Audio Timing Drum Replacement, Tempo Mapping, Useful Macros, Transformations, Layer/Takes/Comps
Simultaneous Audio Interfaces: Audiobox 1818VSL, RME 9632, Line 6 UX2, HF Presonus HP-60
DAWs: Studio One Pro 2.6.1, Reaper 4.5, Sonar X3c Pro, Adobe Audition CS5
Computer: OS:Win7 64-bit, Core i7 950, ASUS P6X58D Premium, 12GB DDR3 1600, GeForce GTX 470 (for CUDA) ,SSD Boot & Cache drives, 1 Tera 7200 RPM SATA II Audio & Video drives, UAD-2 x2
[WWW]
juhanihemmila
Prenoob

Joined: 15/02/2013 16:01:23
Messages: 41
Location: Stockholm, Sweden
Offline

Great news with the update, but I am at a slight loss here: the download starts Automator on my Macbook Pro and from there I get nowhere. What am I doing wrong here? I´ve tried to download the update from both the S1 start page and from within a song, with the same result. Both lead to the same thing: no success, some confusion and this message...

Any help highly appreciated!

/J
mikeolsonstudio
Prenoob

Joined: 18/01/2013 18:34:01
Messages: 5
Offline

I'm having the same issue.

I've tried updating from within S1, it downloads then quits the program not doing anything.

I've also tried downloading the installer from the website. This downloads and installs fine, but it's the same version number (2.5.0)!

Any help would be greatly appreciated.

I'm on Windows 8 64-bit.
mj19577
Prenoob
[Avatar]

Joined: 19/08/2010 01:15:11
Messages: 53
Location: Israel
Offline

I have problems updating to the new version either by the self updater or downloading from "my software"
the version remains on 2.5.0 and not 2.5.1 , any help ?
[WWW]
juhanihemmila
Prenoob

Joined: 15/02/2013 16:01:23
Messages: 41
Location: Stockholm, Sweden
Offline

Good to hear that I´m not alone here. I´m sure help is on its way from Presonus. By the way, I´m on OSX 10.6.8.

/J
urban-115musiq
Prenoob
[Avatar]

Joined: 12/01/2013 18:38:01
Messages: 9
Offline

mj19577 wrote:I have problems updating to the new version either by the self updater or downloading from "my software"
the version remains on 2.5.0 and not 2.5.1 , any help ?

^^^ same with me win7 64bit

This message was edited 2 times. Last update was at 25/02/2013 19:27:54

dwilliams660
Prenoob

Joined: 07/07/2012 07:55:15
Messages: 3
Offline

I have problems too updating to the new version either by the self updater or downloading from the my software......I'm still at the same version on my MAC 2.5.0

This message was edited 1 time. Last update was at 25/02/2013 19:35:58

 
Forum Index » Studio One General Discussion
Go to: