image description


1818 VSL works with current versions of Ubuntu(Linux) and ALSA
  Forum Index » AudioBox VSL 1818 
Author
Message
in2mu5ic
Prenoob

Joined: 29/09/2012 03:36:04
Messages: 3
Offline

See my previous post for my experience in getting the 1818 to work with Sonar X1d Producer.

http://forumsarchive.presonus.com/posts/list/28974.page#195037

My workstation is a dual boot setup with one hard drive dedicated to Windows and my complete DAW running Windows 7 and another hard drive dedicated to running Ubuntu 12.04(Linux). I'm a software engineer by trade and musician by hobby so I need to have Linux. I've got a comfy workstation setup so I like to use the single machine for my DAW and other stuff like work, web browsing, etc. But... when I'm in Linux I also want to have sound through my main audio interface for listening to music, news, etc. through my monitors and not have to deal with additional hardware and speakers that will work with Linux.

When I recently switched to the Presonus interface it was because it was reported that it would work in Linux with newer versions of ALSA. So, I just wanted to report that it does in fact work with Linux, too -- with some minor tweaks and caveats.

It is recognized by ALSA in Ubuntu and you can go into alsamixer and control the muting of channels and volume. It is *not* recognized by the pulseaudio libraries so it won't appear in the volume control applet as a device to control on the menu bar at the top of screen -- but don't fear it's still recognized by ALSA. I won't go into details but the Linux audio subsystem world is kind of confusing to say the least and you need to dump pulseaudio.

To get things to work I disabled pulseaudio audio server from starting(you could also just uninstall it). This is essential since if pulseaudio is running it will not work. Browse Google for various ways to disable or uninstall it -- it's simple. Then I went into the alsa base conf file and set the USB audio device to occupy the 'default' position of 0. Basically changing every reference at the bottoms of:

/etc/modprobe.d/alsa-base.conf

so they're all 0 like:

<stuff before here>

options snd-usb-audio index=0
options snd-usb-caiaq index=0
options snd-usb-ua101 index=0
options snd-usb-us122l index=0
options snd-usb-usx2y index=0

<stuff in between here>

# Intentinoally loaded as first soundcard
options snd-usb-audio index=0

Then I rebooted and ran gstreamer-properties from the command line. This sets up the audio device for all things like playing mp3s, videos, etc.

When the gstreamer-properties UI comes up choose ALSA as the input and output and Default as the device for each also -- DON'T CHOOSE USB.

Press the test button for playback and you should hear a test tone. I was pleasantly surprised when I did!

Anyway, then I just control the volume from the hardware knob on the interface(which is close by underneath my display). Alternately you could go into alsamixer and control it there from the OS.

Now you can play mp3s, YouTube videos, etc. and hear the sound.

NOTE: If you ever reboot and for some reason you hear no sound and running 'aplay -l' doesn't list the AudioBox device, simply run the following command to reload ALSA and it'll pick up the interface:

sudo alsa force-reload

Then run 'aplay -l' and you should see it listed. You can then go about playing music and such again.

I've also heard that folks have got it working for recording using jack audio server and doing recording with applications like Ardour. I've not done any recording myself in Linux -- just playing back audio. So, I can't help there. I couldn't honestly recommned any interface for serious audio work in Linux. It's just too undocumented and unsupported.

Good luck!


This message was edited 4 times. Last update was at 01/10/2012 04:43:07

 
Forum Index » AudioBox VSL 1818
Go to: