image description


How I got my Firestudio 26x26 to Work In Lion
  Forum Index » Firestudio - Legacy 
Author
Message
glantonm
Prenoob
[Avatar]

Joined: 14/10/2011 10:50:30
Messages: 8
Location: Dallas, TX
Offline

FYI - I was have all the same problems that many have reported with FS26x26 after I upgraded from Snow Leopard to Lion. So, I upgraded to the latest driver using the one of the Lion compatible installers for the FS family. The driver got my FS working, but the Universal Controller (1.5.2) only partially worked. That is, I could not set the clock source nor was the mixer available. So, I tried downgrading back to the 1.2 UC, but kept getting error messages about a newer driver being present.
So, I did some searching for a way to completely remove all FS software and drivers. I found this:

http://support.presonus.com/entries/113168-firestudio-family-how-do-i-uninstall-reinstall-my-firestudio-drivers-on-a-mac-computer

It took about 10 minutes, but I follow the steps exactly (including resetting my PRAM). Then, I installed the current FireStudio 26x26 driver (3.5.5) and Universal Controller (1.2.2715) bundle. I really didn't expect much, but to my surprise, everything started working flawlessly!

So, now I have a fully functioning FS26x26 with Universal Control and mixer under Lion (10.7.2)!!!

I hope this helps some of you who have been experiencing the same frustrations as I have!

This message was edited 1 time. Last update was at 21/10/2011 19:42:21

Michael G. - G2 Audio
Mobile Recording in DFW
FireStudio 26x26
Digimax FS
ART DI/O Dual Tube Preamp
MacBook Pro - Logic Pro
[WWW]
Jason.Harris
Presonoid

Joined: 01/10/2010 16:19:09
Messages: 1649
Location: Baton Rouge, LA
Offline

We have the new 2626 driver in alpha stage right now, so we can't try all of this on our systems. If anyone else gets this to work, Please let me know!!!

glantonm
Prenoob
[Avatar]

Joined: 14/10/2011 10:50:30
Messages: 8
Location: Dallas, TX
Offline

We have the new 2626 driver in alpha stage right now, so we can't try all of this on our systems. If anyone else gets this to work, Please let me know!!!


Jason, are those alpha drivers for Mac or Windows? Also, I find it interested that I was able to get the 2626 working on my Mac with a complete manual uninstall of all my Presonus software and drivers, then simply re-installing the latest Snow Leopard package. Is it possible that there was some left over crud from earlier versions that was causing it to get wonky in Lion?
Michael G. - G2 Audio
Mobile Recording in DFW
FireStudio 26x26
Digimax FS
ART DI/O Dual Tube Preamp
MacBook Pro - Logic Pro
[WWW]
skip jones
Presonoid
[Avatar]

Joined: 28/07/2010 15:38:49
Messages: 1744
Location: Corpus Christi, Texas
Offline

@ Glantonm

EXCELLANT, I think.

If your thing works, and PreSonus is working on their own thing, this will make a lot of 26X26 folks happy!

Greets

Skip
http://support.presonus.com/home

Windows 7 X 32 (SP1) : AMD Phenom II X 4 945
ATI Radeon 5450 / 512 RAM
8GB RAM/1T SATA 7200 RPM

PreSonus StudioLive 16.4.2, PreSonus FireStudio Project, PreSonus ABVSL 44, PreSonus ABVSL 1818, PreSonus Faderport

Yamaha S-08
Studio partner - Jack Russell named "Skooter"
PreSonus Studio One Professional 2.6.2
Fishman Triple Play / Logidy pedal
bensrokosz
Prenoob

Joined: 23/07/2011 02:35:47
Messages: 32
Location: Ontario, Canada
Offline

glantonm,

Keep testing it out and let us know if it keeps working! I did this myself back in August with my iMac, however it would crash at weird times and be unrecoverable. For example, core audio service would come on and I would have no audio, or the computer would sleep and when I'd wake it there would be no audio device....etc.

It is possible tat with the last couple of Lion updates that apple has sent out, that the issue is resolved with the old 1.2 driver....I just haven't gone back and retried it.

Please post again with an update
Reaper 4.x
Presonus Firestudio 26x26
Presonus Digimax LT
Joemeek SC VC-1
[WWW]
glantonm
Prenoob
[Avatar]

Joined: 14/10/2011 10:50:30
Messages: 8
Location: Dallas, TX
Offline

I've been using it for a couple of days now pretty heavy. It's been very stable even after going to sleep, turing the FS off and on, logging out of my main account and then logging in under my "audio" account. All of these activities would cause problems for me even (occasionally) under Snow Leopard. Since I have completely uninstalled and re-installed, it has been rock solid stable.

I have to agree with you on the Apple updates. I'm inclined to think that the problem was with likely with Apple because it was super flakey under 10.7.0. I don't know for sure what driver I was on though. All I know is that with 3.5.5+UC1.2 under 10.7.2, it's running perfectly.

This message was edited 1 time. Last update was at 22/10/2011 16:38:09

Michael G. - G2 Audio
Mobile Recording in DFW
FireStudio 26x26
Digimax FS
ART DI/O Dual Tube Preamp
MacBook Pro - Logic Pro
[WWW]
pianofinger
Prenoob

Joined: 02/10/2010 18:01:15
Messages: 4
Offline

I was able to get it to work as well by using Cleanapp to delete all files related to Presonus. I am still tweaking my settings to see if it will work as well as it did pre Lion install.
glantonm
Prenoob
[Avatar]

Joined: 14/10/2011 10:50:30
Messages: 8
Location: Dallas, TX
Offline

Well, if Presonus ever needed a reason to create an uninstaller, this is it! IMHO, users shouldn't have to buy a $15 app to clean the Presonus stuff off their system so they can reinstall and get their gear working.

FYI - I've been editing in Logic all afternoon and it's been running great! I even spent about 10 minutes putting UC through the paces simulating a recording session... panning a mic around in the headphones, assigning it to different mixes and whatnot. Still no problems!
Michael G. - G2 Audio
Mobile Recording in DFW
FireStudio 26x26
Digimax FS
ART DI/O Dual Tube Preamp
MacBook Pro - Logic Pro
[WWW]
1jlp!
Prenoob

Joined: 23/10/2011 00:06:33
Messages: 7
Offline

I followed every step again to delete old driver info, then reloaded 1.2 just like you said in my new iMac shipped with Lion. When I open UC I get no window, no mixer, no nothing. Just the icon in the dock and the words Universal Control in the menu bar showing that it is open. I was so excited to think that it might finally work.

So, pianofinger, please tell what computer you are using.
pianofinger
Prenoob

Joined: 02/10/2010 18:01:15
Messages: 4
Offline

I am using a late 2010 Imac with the latest 10.7.2. Strangely enough, My sound on my Imac went out except for system sounds. I reinstalled the 10.7.2 update and was able to get everything running again after a reboot. So far no more hiccups.
1jlp!
Prenoob

Joined: 23/10/2011 00:06:33
Messages: 7
Offline

Thanks for the info. Looks like because I'm in the "shipped with Lion" group, Im stuck waiting for the actual Lion driver.

So, just to make sure I'm not leaving out a step...normally when one opens UC, the mixer comes right up, right?
skip jones
Presonoid
[Avatar]

Joined: 28/07/2010 15:38:49
Messages: 1744
Location: Corpus Christi, Texas
Offline

There is an option to open on startup in the settings window on UC. Open it and tick/check that and it will open on startup.

Skip
http://support.presonus.com/home

Windows 7 X 32 (SP1) : AMD Phenom II X 4 945
ATI Radeon 5450 / 512 RAM
8GB RAM/1T SATA 7200 RPM

PreSonus StudioLive 16.4.2, PreSonus FireStudio Project, PreSonus ABVSL 44, PreSonus ABVSL 1818, PreSonus Faderport

Yamaha S-08
Studio partner - Jack Russell named "Skooter"
PreSonus Studio One Professional 2.6.2
Fishman Triple Play / Logidy pedal
soldano
Prenoob

Joined: 23/10/2011 18:18:34
Messages: 1
Offline

Thanks for the assist, I have a brand new 2011 iMac that shipped with Lion and it is now working perfectly!

This message was edited 1 time. Last update was at 23/10/2011 18:19:19

tomorrowstk
Presonic
[Avatar]

Joined: 11/11/2010 03:14:29
Messages: 121
Offline

I would like add something for this process as well.

After you have uninstalled all of the presonus software. Go to apples website and search for the 10.7.2 Combo Update. Always download and run the OS X updates from the website that state they are the "Combo" update. I use to have issues all of the time years ago with PTHD and others after using the software updater in OS X but after I started using the combo update packages I never had issues again.

Just thought I would add this to the process. Hope it helps.
http://www.allmusic.com/artist/travis-knight-p94613/credits
1jlp!
Prenoob

Joined: 23/10/2011 00:06:33
Messages: 7
Offline

I'm just not having any good luck. I've been fighting with this off and on since July. I've deleted all old driver info at least 5 or 6 times, repaired disc permissions, reset PRAM, and reinstalled UC 1.2 and even tried UC 1.5.2 (just to see if I could get it to even recognize the FireStudio) and nothing has even come close to working. I've never seen a mixer or a blue light. I even spent the $15 and bought Cleanapp out of desperation. But after using it I still had to go through manually and delete about half of the PreSonus/UC files. (Anyone using Cleanapp might want to keep an eye out, it wanted to delete the whole Juce folder and not just the PreSonus files. It would have taken some other files with it.)

So, even without plugging the FireStudio in, when everyone else opens UC, you see a UC launch window, and not just the words Universal Control in the menu bar, right? I saw a launch window in 1.5.2, but not at all in 1.2. (I do know that 1.5.2 doesn't work with this configuration.)

I'm trying to establish whether or not I have a defective FireStudio, or I'm still just dealing with a driver issue. I did try different cables too.

Thanks for all of the help so far.

This message was edited 1 time. Last update was at 25/10/2011 18:58:27

 
Forum Index » Firestudio - Legacy
Go to: