image description


setting the inputs/outputs of multiple tracks at once
  Forum Index » Studio One Feature Requests 
Author
Message
dieterhartmann
Prenoob
[Avatar]

Joined: 05/03/2014 19:36:15
Messages: 24
Offline

Is there any way to set multiple Midi Tracks to have the same input without having to do so one track at a time?
This has got to be possible. Also consecutive Midi channel outputs on multiple tracks? (Vep1,2,3,4,5,6....)
Also, is there a way to take ALL tracks out of Record enable or change the automation status of ALL tracks to Read?

Any answers would be great.
MAC Pro 10.8.5
Avid Omni
VEP
Bla Bla
http://www.dieterhartmann.com
[WWW]
ricstudioc
Presonic
[Avatar]

Joined: 05/01/2011 22:49:35
Messages: 408
Offline

dieterhartmann wrote:Is there any way to set multiple Midi Tracks to have the same input without having to do so one track at a time?
Also, is there a way to take ALL tracks out of Record enable or change the automation status of ALL tracks to Read?

Any answers would be great.


Well, to the above - I'm pretty sure (not at the DAW right now) you can simply select all tracks (click on the first, shift-click on the last) and make such selections as needed. MOST functions in S! seem to follow that logic.

As to consecutive midi output numbers - don't think there's anyway to have that automatically happen, you'd need to track-by-track that.

Anyone else?
Ric

"The amazing thing about the dancing bear is not how gracefully it dances - it's that it dances at all."
dieterhartmann
Prenoob
[Avatar]

Joined: 05/03/2014 19:36:15
Messages: 24
Offline

Nope. Not possible. This is highly annoying.
If you have an Orchestral template with 90 tracks and you change your input device you have to manually change 90 tracks.
LAME.
MAC Pro 10.8.5
Avid Omni
VEP
Bla Bla
http://www.dieterhartmann.com
[WWW]
Kahlbert
Presonificator

Joined: 27/11/2009 14:17:13
Messages: 4778
Location: Germany
Offline

Why would you change you Input device? Just leave it to "All" and you're good, aren't you?

As for Output (the VSTi your MIDI goes to) it works just like ricstudioc said. You don't even need a modifier key.

Record Enable works the same way, and Automation mode (tried here in the mixer) as well.

So either I heavily misunderstood what you are trying to do, or you just have to look a little closer before shouting out a sweeping "LAME".

This message was edited 1 time. Last update was at 06/03/2014 22:24:27

[WWW]
ricstudioc
Presonic
[Avatar]

Joined: 05/01/2011 22:49:35
Messages: 408
Offline

Kahlbert wrote:Why would you change you Input device? Just leave it to "All" and you're good, aren't you?


Well, since you mention this -

In every iteration of S1 since 1.6 (where I came on board) I've noted a little...bug?... in that. If I record something with an input (midi) set to "All", I hear it as I'm tracking, and the data shows on screen. But when I play back, I get nothing. Nada. As long as I specify the input to one of the keyboards (several different controllers) everything works fine - but "All" predictably exhibits the above behavior.

And a friend of mine who uses S1 called me one day saying his midi wasn't working. Same symptoms. I asked what his input was set for - sure enough, "All". Had him specify one of his controllers- all good.

Beats me - simple enough to avoid, so I haven't thought about it in ages....
dieterhartmann
Prenoob
[Avatar]

Joined: 05/03/2014 19:36:15
Messages: 24
Offline

You're partially right. I can set outputs on Midi tracks this way but all going to the same channel and not sequentially (1, 2, 3, 4....)
However, I can not set multiple Outputs (as I said before) on midi tracks. Why does it work on Outputs but not on Inputs?
I also can't set multiple Audio tracks to the same Input by selecting them (shift).
And I can not set Multiple tracks to "Volume" automation. (or any other type). I can only switch automation state (read, write) this way.
So this is what I was referring to.
It's fine if you're working with 10 tracks but it's really cumbersome, or LAME , when you're doing sessions with 100+ Tracks.
If I am wrong about any of this please correct me.
The manual isn't really detailed.

Thank you

MAC Pro 10.8.5
Avid Omni
VEP
Bla Bla
http://www.dieterhartmann.com
[WWW]
dieterhartmann
Prenoob
[Avatar]

Joined: 05/03/2014 19:36:15
Messages: 24
Offline

i meant multiple INPUTS on Midi Tracks which isn't really a problem due to the "All Inputs" option
MAC Pro 10.8.5
Avid Omni
VEP
Bla Bla
http://www.dieterhartmann.com
[WWW]
Jlien X
Presonic
[Avatar]

Joined: 21/03/2013 13:02:31
Messages: 476
Location: Tokyo
Offline

Why does S1 even show input devices in the input drop-down list and have the "Default Instrument Input" option available in Options > External Devices if "All Inputs" doesn't cause ANY problem at all?
PC: ProBook 4710s, Core2 Duo CPU T9600 @2.80GHz, 8GB RAM
OS: Windows 7 Professional (Japanese) 64-bit SP1
Audio/MIDI: Quad-Capture (interface), A-800PRO (keyboard controller)
DAW: Studio One Producer 2.6.2 (64-bit), SONAR X3e (64-bit)
 
Forum Index » Studio One Feature Requests
Go to: