image description


[2.6.2] issue with track selection
  Forum Index » Studio One General Discussion 
Author
Message
dr4kan
Presonic
[Avatar]

Joined: 25/08/2013 13:40:40
Messages: 590
Offline

Hi,

I have a strange issue when selecting adjacent tracks using Shift + Up/Down key. If use the mouse (Shift + click) everything works as expected, but with the keyboard strange things happen to the events in the project...take a look at the animated gif (at the beginning I use the mouse and then I try the same thing with Shift + Down).

Anyone else?
track selection.gif
[Thumb - track selection.gif]
 Description [Disk] Download
 Filesize 663 Kbytes
 Downloaded:  293 time(s)

This message was edited 4 times. Last update was at 24/01/2014 17:01:39

System: Mac i7, 16 GB ram, 2 x SSD Samsung 840 Pro 256 GB + 1 x SSD Samsung 840 Pro 512 GB + 2 X 2TB HDD (backup), OSX 10.8.4

Hardware: 2xMr816X, 2x896mk3, Ultralite, Adam A7X, CC121, MCU
scottyo7
Presonic
[Avatar]

Joined: 21/11/2012 01:42:35
Messages: 579
Location: Seattle, WA., USA
Offline

Oh boy... here we go... possibly more bugs inadvertently introduced in the "New Update" .

I'll check it out for sure 2nite when I'm back in my lair.
ASUS G75VX, i7 3820QM, 16GB Ram, 2 Samsung 840 256GB SSD's; Win8.1 64; Thunderbolt-Firewire 800 converter (TI chipset).
S1P 2.6.1; PreSonus FP10; EZdrummer 2.0.1, 64; Alchemy 1.55 64. Melodyne Editor 64 - 2.1.2; Izotope Alloy 2 & Ozone 5.
Carvin, ESP, Ibanez, Martin & Yamaha guitars.
Roland Fantom S; Rode NT1; SM58. Line 6 POD HD500 & POD XT-Live. BBE 422A; KRK Rokit 8 Powered Studio Monitors.
Band site: https://soundcloud.com/2guyzinabasement
[WWW]
detachment
Presonic

Joined: 14/02/2012 20:13:42
Messages: 152
Offline

Yes, same thing here...new bug!!! Good going Presonus.

After demo of Bitwig...I will choose between Cubase or Bitwig...cannot tolerate this S1 DAW anymore. None of the request producers requested in past 2 years have been implemented...Impact still low quality, no proper automation, no proper tempo automation, support of external analog synths is almost none existant, MIDI is at best words mediocre, piano roll is...no comment...color scheme is still completely outdated...mixer and it's meters are terrible...I am really not satisfied. I know, people will think now: omg look at that whiner...but I don't lie, truth speaks for itself. S1 is half finished product...

This message was edited 1 time. Last update was at 24/01/2014 23:10:23

http://glacialmovements.bandcamp.com/album/calm-before-the-storm
hibidy
Presonoid

Joined: 01/02/2011 09:13:29
Messages: 2320
Offline

edit

n/m

This message was edited 1 time. Last update was at 24/01/2014 23:44:07

New computer:

2.6.2/win7x64 ultimate/SSD os and library/i7 4770/16GB ram

Focusrite saffire 14/Novation impulse 49/tons of VST goodies

jpettit
Presonoid
[Avatar]

Joined: 13/01/2011 23:44:45
Messages: 2211
Location: Portland Oregon
Offline

dr4kan wrote:Hi,

I have a strange issue when selecting adjacent tracks using Shift + Up/Down key. If use the mouse (Shift + click) everything works as expected, but with the keyboard strange things happen to the events in the project...take a look at the animated gif (at the beginning I use the mouse and then I try the same thing with Shift + Down).

Anyone else?

Cant replicate here. So far...
Upon re-downloading an re-viewing the video I see the clip selection action going on now in my system. I thought it was an issue of erratic selection but it is not.
Confirmed.

This message was edited 2 times. Last update was at 29/01/2014 22:09:40

My Website
FRs: Tempo Detection & Mapping
Training Videos: Advance Melodyne, Creating Macros, 2.5 New Features, Signal Flow, Audio Timing Drum Replacement, Tempo Mapping, Useful Macros, Transformations, Layer/Takes/Comps
Simultaneous Audio Interfaces: Audiobox 1818VSL, RME 9632, Line 6 UX2, HF Presonus HP-60
DAWs: Studio One Pro 2.6.1, Reaper 4.5, Sonar X3c Pro, Adobe Audition CS5
Computer: OS:Win7 64-bit, Core i7 950, ASUS P6X58D Premium, 12GB DDR3 1600, GeForce GTX 470 (for CUDA) ,SSD Boot & Cache drives, 1 Tera 7200 RPM SATA II Audio & Video drives, UAD-2 x2
[WWW]
dr4kan
Presonic
[Avatar]

Joined: 25/08/2013 13:40:40
Messages: 590
Offline

detachment wrote:Yes, same thing here...new bug!!! Good going Presonus.

After demo of Bitwig...I will choose between Cubase or Bitwig...cannot tolerate this S1 DAW anymore. None of the request producers requested in past 2 years have been implemented...Impact still low quality, no proper automation, no proper tempo automation, support of external analog synths is almost none existant, MIDI is at best words mediocre, piano roll is...no comment...color scheme is still completely outdated...mixer and it's meters are terrible...I am really not satisfied. I know, people will think now: omg look at that whiner...but I don't lie, truth speaks for itself. S1 is half finished product...


Thanks for checking. So you also have that. Are you on Mac?

jpettit wrote:
Cant replicate here. So far...
Perhaps yo could try with a simple test song to see what the condition is?


Thanks for checking. I will try to debug this. Anyway, I did not have this problem with the previous versions but it's just with 2.6.2. Maybe it's a OSX problem only and that's why you cannot replicate. Anyway I will spend some time on this....

This message was edited 2 times. Last update was at 25/01/2014 00:47:35

System: Mac i7, 16 GB ram, 2 x SSD Samsung 840 Pro 256 GB + 1 x SSD Samsung 840 Pro 512 GB + 2 X 2TB HDD (backup), OSX 10.8.4

Hardware: 2xMr816X, 2x896mk3, Ultralite, Adam A7X, CC121, MCU
hibidy
Presonoid

Joined: 01/02/2011 09:13:29
Messages: 2320
Offline

2.6.3? I'm guessing that was a typo.
New computer:

2.6.2/win7x64 ultimate/SSD os and library/i7 4770/16GB ram

Focusrite saffire 14/Novation impulse 49/tons of VST goodies

LMike
Baconator
[Avatar]

Joined: 19/02/2011 12:02:34
Messages: 8233
Offline

Hmmm .... I can reproduce this here, that using Shift + Down Arrow also selects all clips on tracks.

I don't typically select track panels that way with that key command but strangely enough, I like the behavior. I mean, Shift + Holding the arrow down makes for a rather quick "Select All".


This message was edited 2 times. Last update was at 25/01/2014 00:14:26

Studio One Tips For Newbs

"So.... Bitwig. I wonder what's queued up next in line on the drama list?"
LMike
Baconator
[Avatar]

Joined: 19/02/2011 12:02:34
Messages: 8233
Offline

Are you certain that changed?

I just tried it in 2.60 and it's doing the same thing.
Studio One Tips For Newbs

"So.... Bitwig. I wonder what's queued up next in line on the drama list?"
detachment
Presonic

Joined: 14/02/2012 20:13:42
Messages: 152
Offline

dr4kan wrote:
Thanks for checking. So you also have that. Are you on Mac?


No, Win7 64bit....64bit S1 Pro! It happens in every project and I can repeat bug over and over again. It's there...thanks for pointing that out!
http://glacialmovements.bandcamp.com/album/calm-before-the-storm
dr4kan
Presonic
[Avatar]

Joined: 25/08/2013 13:40:40
Messages: 590
Offline

hibidy wrote:2.6.3? I'm guessing that was a typo.


sure, a typo. I edited it.

LMike wrote:Hmmm .... I can reproduce this here, that using Shift + Down Arrow also selects all clips on tracks.

I don't typically select track panels that way with that key command but strangely enough, I like the behavior. I mean, Shift + Holding the arrow down makes for a rather quick "Select All".


If you look at my animated gif carefully you will notice that the behavior is strange. sometimes it selects all clips, sometimes it selects some clips, sometimes it selects nothing. unpredictable behavior. definitely not there before as I always use the shift + arrows to select adjacent tracks.
System: Mac i7, 16 GB ram, 2 x SSD Samsung 840 Pro 256 GB + 1 x SSD Samsung 840 Pro 512 GB + 2 X 2TB HDD (backup), OSX 10.8.4

Hardware: 2xMr816X, 2x896mk3, Ultralite, Adam A7X, CC121, MCU
dr4kan
Presonic
[Avatar]

Joined: 25/08/2013 13:40:40
Messages: 590
Offline

Ok, I did few more tests. I attach here an animated gif showing the problem starting from an empty project. I just added an instance of Addictive Drums and some mono tracks. At the beginning of the video I test the classic Shift + click method and everything works as expected, then I try to do Shift + arrow keys to select adjacent tracks (you can notice that part by the fact the mouse doesn't move...) and strange thing happens. Some parts become selected and others don't, without a schema.

I also checked that this did not happen before. For the moment we are just two seeing this...can anyone else confirm? It reminds me the issue with the cursor in 2.6.0 (solved in 2.6.1) that just few OSX users had (naturally I was one of the lucky...)

PS: once an image is uploaded how to include it in the post directly? I mean, the <img> </img> stuff requires an url, how to tell this guy to point to the attached image?
selection issue.gif
[Thumb - selection issue.gif]
 Description [Disk] Download
 Filesize 1941 Kbytes
 Downloaded:  181 time(s)

System: Mac i7, 16 GB ram, 2 x SSD Samsung 840 Pro 256 GB + 1 x SSD Samsung 840 Pro 512 GB + 2 X 2TB HDD (backup), OSX 10.8.4

Hardware: 2xMr816X, 2x896mk3, Ultralite, Adam A7X, CC121, MCU
skorpius
Prenoob

Joined: 06/01/2014 13:05:31
Messages: 9
Offline

dr4kan wrote:
Anyone else?


No - I can NOT confirm this. Just tried it in 2.6.1, and it works just the way it should. All adjacent tracks are selected when using the shift key plus arrow button. It works perfectly both ways, upward and downwards.

Anyway, it's good to know how easily adjacent tracks can be selected. I wasn't really aware of this method.

dr4kan
Presonic
[Avatar]

Joined: 25/08/2013 13:40:40
Messages: 590
Offline

skorpius wrote:
dr4kan wrote:
Anyone else?


No - I can NOT confirm this. Just tried it in 2.6.1, and it works just the way it should. All adjacent tracks are selected when using the shift key plus arrow button. It works perfectly both ways, upward and downwards.

Anyway, it's good to know how easily adjacent tracks can be selected. I wasn't really aware of this method.



thanks for the feedback, but...It's a typo or did you test on 2.6.1? because we are talking about 2.6.2 here. I did not have any issue on 2.6.1. About <<All adjacent tracks are selected when using the shift key plus arrow button>>, look it's not that the issue. Have you seen my .gif and read my description of the problem?
System: Mac i7, 16 GB ram, 2 x SSD Samsung 840 Pro 256 GB + 1 x SSD Samsung 840 Pro 512 GB + 2 X 2TB HDD (backup), OSX 10.8.4

Hardware: 2xMr816X, 2x896mk3, Ultralite, Adam A7X, CC121, MCU
LMike
Baconator
[Avatar]

Joined: 19/02/2011 12:02:34
Messages: 8233
Offline

I'll try to confirm again the next time i launch S1.

It does seem to maybe be behaving differently, by looking at your gifs. It might be a good idea to explain why that change is problematic for you in a practical sense when you select multiple tracks. I'm not suggesting that it's not problematic for you, on the contrary.

Just more wondering if it's a visual thing or a practical thing, if it affects editing or working in some practical way. If the latter is the case it might also be good to detail why that happening that way now is problematic, to maybe give it more priority.
Studio One Tips For Newbs

"So.... Bitwig. I wonder what's queued up next in line on the drama list?"
 
Forum Index » Studio One General Discussion
Go to: