image description


Will FireStudio provide low-latency performance comparable to a PCMCIA card with right FW chipset?
  Forum Index » Pre-Sales Questions 
Author
Message
jacobfk
Prenoob

Joined: 10/10/2010 22:59:58
Messages: 7
Offline

Hello--

I just bought a Firestudio Mobile with the intent of using it as my primary audio interface, and just using my Echo Indigo PCMCIA card when I really want that degree of portability. Obviously the FSM is more flexible, so I really want to like it.

Unfortunately the low-latency performance on the FSM isn't nearly as good as the Indigo on my machine. I can go down to 128 samples on the Indigo and get glitch-free operation, whereas with the FSM I need to bump it up to 256, which given the additional overhead of the FSM is enough to bother me when tracking.

The OHCI Tool does inform me that my Ricoh FW Chipset is supposedly incompatible with the DICE chipset on the FSM. My question is, will I get a significant performance boost from a TI-equipped FW card, or is that more of a recommendation when the FSM does not work at all with one's Ricoh chipset?
Monolithent
Supreme Baconator
[Avatar]
Joined: 28/07/2010 18:47:25
Messages: 13464
Location: Central New Jersey
Offline

Hi and welcome.

The thing you want to concern yourself with in this case would be the Ricoh itself. It's very very common that its controlling more than just firewire on your laptop. Adding a pcmcia or expresscard may not help matters. If you're not gonna lose too much sleep over the cost of the card, I'd say give it a shot. I don't think it could get worse at this point.
http://support.presonus.com

Tallest guy in the Mod Squad with all his hair still on his head.

No I'm not a freaking pilot!! The Air Force won't let me have a suit with a zipper...or sometimes shoestrings.

My advice and suggestions should never be considered advice or suggestions. These are mostly insane ramblings of a poor aircraft mechanic who can, strangely enough, still hear.

StudioLive 16.4.2, AudioBox 1818VSL, AudioBox 44VSL, Faderport, Digimax FS,, M-Audio Firewire 410
--MultiBoot System--
Win Vista 64/XP Pro/7 x86/7 x64 - Mac OSX Snow Leopard/Lion
Gigabyte motherboard--SYBA TI Firewire XIO2200A--i7 2600k Quad Core--16 GB DDR III--Custom 2U Rackmount--4 TB Raid (all internal SATA II)--19" Samsung HDMI LCD on pivoting VESA 1U Mount
Studio One v1 Pro x64
Studio One v1 Artist
Studio One v2 Artist
[Yahoo!]
jacobfk
Prenoob

Joined: 10/10/2010 22:59:58
Messages: 7
Offline

I am now getting what I consider acceptable performance out of the FSM now that I've done some DAW 101 tweaks such as disabling Windows Aero (don't really need semi-transparent window headers...) and disabling my wireless adapter (not just switching it off...)

The fact that direct-PCMCIA Echo interface is so forgiving towards latency-exacerbating DAW no-nos leads me to believe that the Ricoh chipset isn't exactly getting in its way, so I would expect to get more configuration-lenient performance with the FSM out of a TI-equipped card, if the Ricoh is supposed to be so bad, right?
talmen
Presonoid
[Avatar]

Joined: 28/07/2010 23:56:13
Messages: 3002
Offline

Ostensibly. Mileage often varies, you won't know for sure until you try.
Field Kit:
MacBook Pro 9.2 i5 2.5 GHz, 8GB RAM,
OS 10.8.5;
A & H Qu-16, AB1818VSL, Alesis IO14 / IO26,
PreSonus S1 v2.6.2.25990, Boom Recorder 8.3.2

Studio Kit:
iMac 11.3, i7 (Quad) 2.93GHz, 8 GB RAM,
OS 10.9.3,
M-Audio FW1814, PreSonus Faderport,
PreSonus S1 Pro 2.6.2.25590
jacobfk
Prenoob

Joined: 10/10/2010 22:59:58
Messages: 7
Offline

Guys--

My relentless googling paid off. I don't need another card, because Ricoh already released a fix for their chipset. They did it in parternship with Digidesign which is why none of the other manufacturers ever heard about it

http://www.digidesign.com/index.cfm?navid=3&downloadid=58920&eid=7930&categoryid=36

Performance with the FireStudio Mobile, through everyone's favorite Ricoh chipset, is now damn near identical to my Echo Indigo IO. 64 samples, here I come
Monolithent
Supreme Baconator
[Avatar]
Joined: 28/07/2010 18:47:25
Messages: 13464
Location: Central New Jersey
Offline

jacobfk,

I have been searching for something that might help those with the Ricoh chipset for months. Do you mind if I drop this link in a thread I started to a help address the problems with connectivity and tweaks. http://forumsarchive.presonus.com/posts/list/3535.page

If it helped out your system with connectivity it might be of use to others with similar woes...and there are a lot of them.
http://support.presonus.com

Tallest guy in the Mod Squad with all his hair still on his head.

No I'm not a freaking pilot!! The Air Force won't let me have a suit with a zipper...or sometimes shoestrings.

My advice and suggestions should never be considered advice or suggestions. These are mostly insane ramblings of a poor aircraft mechanic who can, strangely enough, still hear.

StudioLive 16.4.2, AudioBox 1818VSL, AudioBox 44VSL, Faderport, Digimax FS,, M-Audio Firewire 410
--MultiBoot System--
Win Vista 64/XP Pro/7 x86/7 x64 - Mac OSX Snow Leopard/Lion
Gigabyte motherboard--SYBA TI Firewire XIO2200A--i7 2600k Quad Core--16 GB DDR III--Custom 2U Rackmount--4 TB Raid (all internal SATA II)--19" Samsung HDMI LCD on pivoting VESA 1U Mount
Studio One v1 Pro x64
Studio One v1 Artist
Studio One v2 Artist
[Yahoo!]
jacobfk
Prenoob

Joined: 10/10/2010 22:59:58
Messages: 7
Offline

It should be dropped anywhere Ricoh chipset issues are being discussed
Monolithent
Supreme Baconator
[Avatar]
Joined: 28/07/2010 18:47:25
Messages: 13464
Location: Central New Jersey
Offline

Thanks

I'm also going to forward it to some of the presonus heads to see if it would be useful.
http://support.presonus.com

Tallest guy in the Mod Squad with all his hair still on his head.

No I'm not a freaking pilot!! The Air Force won't let me have a suit with a zipper...or sometimes shoestrings.

My advice and suggestions should never be considered advice or suggestions. These are mostly insane ramblings of a poor aircraft mechanic who can, strangely enough, still hear.

StudioLive 16.4.2, AudioBox 1818VSL, AudioBox 44VSL, Faderport, Digimax FS,, M-Audio Firewire 410
--MultiBoot System--
Win Vista 64/XP Pro/7 x86/7 x64 - Mac OSX Snow Leopard/Lion
Gigabyte motherboard--SYBA TI Firewire XIO2200A--i7 2600k Quad Core--16 GB DDR III--Custom 2U Rackmount--4 TB Raid (all internal SATA II)--19" Samsung HDMI LCD on pivoting VESA 1U Mount
Studio One v1 Pro x64
Studio One v1 Artist
Studio One v2 Artist
[Yahoo!]
talmen
Presonoid
[Avatar]

Joined: 28/07/2010 23:56:13
Messages: 3002
Offline

Wow, that is exciting! I really hope this may provide much needed relief for some of the people who have been struggling to get their systems performing more stably.
Field Kit:
MacBook Pro 9.2 i5 2.5 GHz, 8GB RAM,
OS 10.8.5;
A & H Qu-16, AB1818VSL, Alesis IO14 / IO26,
PreSonus S1 v2.6.2.25990, Boom Recorder 8.3.2

Studio Kit:
iMac 11.3, i7 (Quad) 2.93GHz, 8 GB RAM,
OS 10.9.3,
M-Audio FW1814, PreSonus Faderport,
PreSonus S1 Pro 2.6.2.25590
jacobfk
Prenoob

Joined: 10/10/2010 22:59:58
Messages: 7
Offline

My "discovery" may not be ready for prime time as I've investigated further and realized the utility isn't actually doing what it's supposed to be doing on my machine, error codes indicating it only does its job on a 32-bit machine. So something is improving the performance relative to DPC latency but it's not that.
Monolithent
Supreme Baconator
[Avatar]
Joined: 28/07/2010 18:47:25
Messages: 13464
Location: Central New Jersey
Offline

I sent the link for it to Rick Naqvi via email. Taht way Presonus can have a look at it and see if there is anything they can do with it.

I would hope they already knew about it but just in case they didn't.

I'm not going to put it on the tweaks thread until they can bless its functionality.
http://support.presonus.com

Tallest guy in the Mod Squad with all his hair still on his head.

No I'm not a freaking pilot!! The Air Force won't let me have a suit with a zipper...or sometimes shoestrings.

My advice and suggestions should never be considered advice or suggestions. These are mostly insane ramblings of a poor aircraft mechanic who can, strangely enough, still hear.

StudioLive 16.4.2, AudioBox 1818VSL, AudioBox 44VSL, Faderport, Digimax FS,, M-Audio Firewire 410
--MultiBoot System--
Win Vista 64/XP Pro/7 x86/7 x64 - Mac OSX Snow Leopard/Lion
Gigabyte motherboard--SYBA TI Firewire XIO2200A--i7 2600k Quad Core--16 GB DDR III--Custom 2U Rackmount--4 TB Raid (all internal SATA II)--19" Samsung HDMI LCD on pivoting VESA 1U Mount
Studio One v1 Pro x64
Studio One v1 Artist
Studio One v2 Artist
[Yahoo!]
jacobfk
Prenoob

Joined: 10/10/2010 22:59:58
Messages: 7
Offline

I found out what caused the performance increase was switching back to the non-legacy driver for the Ricoh. The legacy driver was needed to get the thing recognized so its firmware could be updated. The updated firmware works with the Win7 driver, and works better.

However, once I start adding tracks and effects, performance quickly degrades into the crackle zone at far lower CPU levels than it should. I'm talking 10-15%. The PCI card doesn't do this.

Like I said before, I really want to like this thing, and I kind of boxed myself into not being able to return it by registering it prior to the warranty deadline, so I ordered the StarTech TI ExpressCard as a Hail Mary of sorts.

If this doesn't improve the performance, I'm either selling the thing or buying a Mac...
jacobfk
Prenoob

Joined: 10/10/2010 22:59:58
Messages: 7
Offline

For the record, I'm testing this on two different computers--Lenovo T400 and T410.
PhilG
Presonoid
[Avatar]
Joined: 29/07/2010 01:46:55
Messages: 1172
Location: Brisbane Australia
Offline

the ricoh chipset still controls the expresscard slot sorry, any data going through the TI FW Card will still pass into the hell gates of ricoh.

dont hold your breath it will work.

2 x SL16.4.2's
Audiobox USB
Studio One V2 Pro
/ Rack System
AMD FX-4170 / 16GB DDR3 / Win7x64 / Via 6308FW Onboard
/Mobile System
Toshiba Satellite P200 / 8GB DDR2 / Win7x64 / Ti FW & i7 13" MBP
/Wireless
Ipad v1 16gb - Samsung Galaxy Tab - Asus Black Diamond router

[Email] [WWW] [ICQ]
 
Forum Index » Pre-Sales Questions
Go to: