image description


[ISSUE] Odd signature and drag & drop...
  Forum Index » Studio One Forum Community Support 
Author
Message
dr4kan
Presonic
[Avatar]

Joined: 25/08/2013 13:40:40
Messages: 590
Offline

Hi guys,

I hope you can cross-check this. This is the problem:

You have 7/8 song and you want to drag & drop some 7/8 midi parts from your favorite drum software (Addictive Drums and Superior Drummer here). If the loop is 2 or 4 bar long you expect that the resulting midi part will be 2 or 4 bar long as well, but this is the problem. It looks like S1 always consider 4/4 long bars. Look at the following gif. I tried with AD and SD. S1 will always add extra space at the end to be "compatible" with a 4/4 long bar. In Cubase 7 (the other DAW I have and I'd like not to use anymore... ) this works as expected.

This is quite annoying as you usually drag & drop many parts to make a full song and you have to manually resize and move each part.

Can you confirm this?

issue D&D.gif
[Thumb - issue D&D.gif]
 Description [Disk] Download
 Filesize 609 Kbytes
 Downloaded:  241 time(s)

System: Mac i7, 16 GB ram, 2 x SSD Samsung 840 Pro 256 GB + 1 x SSD Samsung 840 Pro 512 GB + 2 X 2TB HDD (backup), OSX 10.8.4

Hardware: 2xMr816X, 2x896mk3, Ultralite, Adam A7X, CC121, MCU
mrpicholas
Presonic
[Avatar]

Joined: 27/04/2011 03:06:14
Messages: 284
Location: California
Offline

None of your screen shots show the bottom of your project where the meter is visible. Is your project in 7/8 or is your project set for 4/4? If the master meter is set for 7/8, and the loops you're importing are 7/8 loops, it should line up with barlines automatically.
MacBook 2.1 GHz Intel Core 2 Duo with 4GB RAM & OS 10.6.8. Studio One Professional 2.6, Notion 4, 2x PreSonus Firestudio Project Interfaces, PreSonus ACP88, PreSonus Sceptre S6, FaderPort, Melodyne Editor 2.1.2, Waves Gold Bundle 9.0, Nomad Factory Integral Studio Pack, Native Instruments Kore 2 & Komplete 6, AAS String Studio & Ultra-Analog VA2. Faber-Castell #2 Pencil
dr4kan
Presonic
[Avatar]

Joined: 25/08/2013 13:40:40
Messages: 590
Offline

mrpicholas wrote:None of your screen shots show the bottom of your project where the meter is visible. Is your project in 7/8 or is your project set for 4/4? If the master meter is set for 7/8, and the loops you're importing are 7/8 loops, it should line up with barlines automatically.


As you can notice by looking at the tempo track in my animated gif, the time signature of the project is set to 7/8 (*), so, as you correctly said, the loop "should line up with bar lines automatically", but it doesn't...so, I'd like to know if it's an issue with my S1 or it's a bug.

Can anyone cross-check?

Thanks.

(*) also by looking at the grid lines, you can verify it's actually 7/8

This message was edited 2 times. Last update was at 12/01/2014 19:06:02

System: Mac i7, 16 GB ram, 2 x SSD Samsung 840 Pro 256 GB + 1 x SSD Samsung 840 Pro 512 GB + 2 X 2TB HDD (backup), OSX 10.8.4

Hardware: 2xMr816X, 2x896mk3, Ultralite, Adam A7X, CC121, MCU
jpettit
Presonoid
[Avatar]

Joined: 13/01/2011 23:44:45
Messages: 2211
Location: Portland Oregon
Offline

Confirmed kind of..

Loop on left is free 7/8 loop from the internet and finishes on 8 measures.
Loop on right is 7/8 loop from AD and it add extra space after the loop.
I tried it with snap on and off to see if that made a difference. It did not.
Both loop play in time with the metronome with the 8th note getting the correct count.

So yes AD adds extra space ( that can me trimmed back to the measure line)

http://www.oddgrooves.com/download-free-78-drum-loops-here/
See if you get the same results.
My Website
FRs: Tempo Detection & Mapping
Training Videos: Advance Melodyne, Creating Macros, 2.5 New Features, Signal Flow, Audio Timing Drum Replacement, Tempo Mapping, Useful Macros, Transformations, Layer/Takes/Comps
Simultaneous Audio Interfaces: Audiobox 1818VSL, RME 9632, Line 6 UX2, HF Presonus HP-60
DAWs: Studio One Pro 2.6.1, Reaper 4.5, Sonar X3c Pro, Adobe Audition CS5
Computer: OS:Win7 64-bit, Core i7 950, ASUS P6X58D Premium, 12GB DDR3 1600, GeForce GTX 470 (for CUDA) ,SSD Boot & Cache drives, 1 Tera 7200 RPM SATA II Audio & Video drives, UAD-2 x2
[WWW]
dr4kan
Presonic
[Avatar]

Joined: 25/08/2013 13:40:40
Messages: 590
Offline

Hi jpettit, thanks for checking!

I confirm your findings, so when I drag & drop from the browser no problem, but the problem appears when I try to do the same thing from a VST drum software, regardless the software...Indeed I also tried EZDrummer and the result is the same, so it's definitely something related to S1...I hope someone at Presonus will take care of this.

This message was edited 1 time. Last update was at 12/01/2014 22:09:01

System: Mac i7, 16 GB ram, 2 x SSD Samsung 840 Pro 256 GB + 1 x SSD Samsung 840 Pro 512 GB + 2 X 2TB HDD (backup), OSX 10.8.4

Hardware: 2xMr816X, 2x896mk3, Ultralite, Adam A7X, CC121, MCU
dr4kan
Presonic
[Avatar]

Joined: 25/08/2013 13:40:40
Messages: 590
Offline

none else had a chance to test this?

I made other tests with different odd signatures and I got the same issue. Sure I can trim back the extra space, but if you drag 20-30 midi parts to make a song-length loop, well it's at least annoying...

System: Mac i7, 16 GB ram, 2 x SSD Samsung 840 Pro 256 GB + 1 x SSD Samsung 840 Pro 512 GB + 2 X 2TB HDD (backup), OSX 10.8.4

Hardware: 2xMr816X, 2x896mk3, Ultralite, Adam A7X, CC121, MCU
 
Forum Index » Studio One Forum Community Support
Go to: