image description


Bug in the "Insert Silence" Action?
  Forum Index » Studio One General Discussion 
Author
Message
SMcNamara
Presonic

Joined: 02/07/2011 06:51:00
Messages: 150
Offline

This involves inserting silence and having the markers follow.

I have confirmed multiple times in different songs that using the Range tool and then clicking CTL+ALT+I does not move the markers. Nor does using the range tool and then clicking on the Edit Menu|Insert Silence. The markers stay where they are. Nor does click+drag plus ALT+R and then CTL+ALT+I. The Markers don't move.

BUT, by not using the range tool first but instead clicking on Edit|Insert Silence, that brings up a dialog box that lets me put in the beginning bar and ending bar for the silence, and that way the markers do move. Maybe I've missed a setting somewhere, but

This message was edited 1 time. Last update was at 08/05/2012 22:38:19

S1Pro 2.6.2 / ASUSB85M-E / Intel i7-4770k / 320GB WD SATA III/ 1TB WD SATA III drives (2) / 16gb Corsair 1600 DDR3 / Antec 620 / Faderport / Focusrite Scarlett 8i8 interface / various other studio toys
talmen
Presonoid
[Avatar]

Joined: 28/07/2010 23:56:13
Messages: 3002
Offline

Way to find those bugs -- now let's get the S1 dev team to squash it! (With apologies to insectophiles.)
Field Kit:
MacBook Pro 9.2 i5 2.5 GHz, 8GB RAM,
OS 10.8.5;
A & H Qu-16, AB1818VSL, Alesis IO14 / IO26,
PreSonus S1 v2.6.2.25990, Boom Recorder 8.3.2

Studio Kit:
iMac 11.3, i7 (Quad) 2.93GHz, 8 GB RAM,
OS 10.9.3,
M-Audio FW1814, PreSonus Faderport,
PreSonus S1 Pro 2.6.2.25590
SMcNamara
Presonic

Joined: 02/07/2011 06:51:00
Messages: 150
Offline

Thanks, Talmen.

As this topic drops away without any comment from S1 I fear it will be overlooked. I think there's a separate forum for problems like this, and if so, will post there.

Steve
S1Pro 2.6.2 / ASUSB85M-E / Intel i7-4770k / 320GB WD SATA III/ 1TB WD SATA III drives (2) / 16gb Corsair 1600 DDR3 / Antec 620 / Faderport / Focusrite Scarlett 8i8 interface / various other studio toys
LMike
Baconator
[Avatar]

Joined: 19/02/2011 12:02:34
Messages: 8233
Offline

I don't think this is a bug.

1. With range selection, insert silence works on individual tracks, and of course, you probably wouldn't want your song markers moving around anytime you insert or delete time on a single track.

2. With no range selection it assumes you'll be inserting or deleting time for the entire song and throws up the dialog. In that case it also inserts or deletes time in both the marker and tempo tracks.

Having said all that, maybe only when the range selection is spanning the entire vertical range (Create Ranges?) should it behave like the second one... and insert or delete time globally, moving markers and tempo changes... make that same assumption... but only then.

I wouldn't want that happening (markers moving) every time I insert / delete silence on a track while arranging media though. That would be a mess.

This message was edited 1 time. Last update was at 08/05/2012 23:02:57

Studio One Tips For Newbs

"So.... Bitwig. I wonder what's queued up next in line on the drama list?"
SMcNamara
Presonic

Joined: 02/07/2011 06:51:00
Messages: 150
Offline

LMike wrote:I don't think this is a bug.

1. With range selection, insert silence works on individual tracks, and of course, you probably wouldn't want your song markers moving around anytime you insert or delete time on a single track.


Mike:

I agree with you about adding silence to individual tracks. BUT when a range is selected and then ALT+R is selected (I believe that's it, I'm at work), the entire vertical range is selected. Posts in other threads have indicated that with ALT+R clicked that the Markers should then move (since all of the tracks have been selected). But they don't.

Oddly enough, I searched through the PDF of the S1 Manual (version 2) and I didn't see anything discussing Insert Silence and Markers. Since it is a menu item I am surprised. But maybe I just missed it
S1Pro 2.6.2 / ASUSB85M-E / Intel i7-4770k / 320GB WD SATA III/ 1TB WD SATA III drives (2) / 16gb Corsair 1600 DDR3 / Antec 620 / Faderport / Focusrite Scarlett 8i8 interface / various other studio toys
LMike
Baconator
[Avatar]

Joined: 19/02/2011 12:02:34
Messages: 8233
Offline

SMcNamara wrote:... when a range is selected and then ALT+R is selected (I believe that's it, I'm at work), the entire vertical range is selected. ... But they don't.


Yeah, I think I actually said that (agree with that) in my post.

"Having said all that, maybe only when the range selection is spanning the entire vertical range (Create Ranges?) should it behave like the second one"

This message was edited 1 time. Last update was at 09/05/2012 00:47:42

Studio One Tips For Newbs

"So.... Bitwig. I wonder what's queued up next in line on the drama list?"
SMcNamara
Presonic

Joined: 02/07/2011 06:51:00
Messages: 150
Offline

LMike wrote:
SMcNamara wrote:... when a range is selected and then ALT+R is selected (I believe that's it, I'm at work), the entire vertical range is selected. ... But they don't.


Yeah, I think I actually said that (agree with that) in my post.

"Having said all that, maybe only when the range selection is spanning the entire vertical range (Create Ranges?) should it behave like the second one"


<Homer Simpson voice> D'oh!
S1Pro 2.6.2 / ASUSB85M-E / Intel i7-4770k / 320GB WD SATA III/ 1TB WD SATA III drives (2) / 16gb Corsair 1600 DDR3 / Antec 620 / Faderport / Focusrite Scarlett 8i8 interface / various other studio toys
maik
Preamp
[Avatar]

Joined: 16/04/2009 10:26:40
Messages: 524
Location: Hamburg/Germany
Offline

LMike wrote:Having said all that, maybe only when the range selection is spanning the entire vertical range (Create Ranges?) should it behave like the second one... and insert or delete time globally, moving markers and tempo changes... make that same assumption... but only then.


I agree, that's how it should be. Will be improved soon...
Maik Oppermann

Software Developer
PreSonus Software
stanft
Prenoob

Joined: 16/02/2012 10:06:59
Messages: 11
Location: Hamburg, Germany
Offline

Will the "delete time" function be improved, too? Because unfortunately it is currently not possible to delete time by entering a range using a popup dialog like it is in the insert time function. Thus, it is currently not possible to move markers with the delete time command.

And in addition: Not only markers have to be moved but time signature changes, too.

Regards,
Stephan
Kahlbert
Presonificator

Joined: 27/11/2009 14:17:13
Messages: 4778
Location: Germany
Offline

stanft wrote:Will the "delete time" function be improved, too? Because unfortunately it is currently not possible to delete time by entering a range using a popup dialog like it is in the insert time function. Thus, it is currently not possible to move markers with the delete time command.

And in addition: Not only markers have to be moved but time signature changes, too.

Regards,
Stephan

[WWW]
LMike
Baconator
[Avatar]

Joined: 19/02/2011 12:02:34
Messages: 8233
Offline

Thinking out loud here a tiny bit ...

One thing I don't particularly like about the Insert Time dialog is that it doesn't automatically assume the current loop I/O range as being the range to use. If it did there would really be no need for a dialog. If you could right click on the ruler and "Insert (or delete) Time" from a context menu there, it could always assume the loop range as the range to remove or insert and you wouldn't need a dialog there, and that one would always work globally... always affecting the tempo and time sig tracks.

Maybe that context menu item would only appear if you right click on the ruler inside the loop range, making the intent pretty literal, dunno.

Obviously, those would be two distinct functions in the action list requiring two distinct key bindings.

This message was edited 1 time. Last update was at 09/05/2012 13:57:57

Studio One Tips For Newbs

"So.... Bitwig. I wonder what's queued up next in line on the drama list?"
LMike
Baconator
[Avatar]

Joined: 19/02/2011 12:02:34
Messages: 8233
Offline

stanft wrote:Will the "delete time" function be improved, too? Because unfortunately it is currently not possible to delete time by entering a range using a popup dialog like it is in the insert time function. Thus, it is currently not possible to move markers with the delete time command.
Regards,
Stephan


I never even noticed that. I assumed it too used the same dialog. Good one.
Studio One Tips For Newbs

"So.... Bitwig. I wonder what's queued up next in line on the drama list?"
SMcNamara
Presonic

Joined: 02/07/2011 06:51:00
Messages: 150
Offline

LMike wrote:
stanft wrote:Will the "delete time" function be improved, too? Because unfortunately it is currently not possible to delete time by entering a range using a popup dialog like it is in the insert time function. Thus, it is currently not possible to move markers with the delete time command.
Regards,
Stephan


I never even noticed that. I assumed it too used the same dialog. Good one.


I hadn't noticed it either. But this is a major deal. Whether you insert or delete a range of time across all tracks you should have the option of moving markers, time signatures, tempo changes, everything.

Of course, if you just want to delete all the existing sounds from a range of time and leave a hole my understanding is a few quick snips and that's easy
S1Pro 2.6.2 / ASUSB85M-E / Intel i7-4770k / 320GB WD SATA III/ 1TB WD SATA III drives (2) / 16gb Corsair 1600 DDR3 / Antec 620 / Faderport / Focusrite Scarlett 8i8 interface / various other studio toys
 
Forum Index » Studio One General Discussion
Go to: