image description


Terrible Repair Services
  Forum Index » Pre-Sales Questions 
Author
Message
skinfrakki
Presonic
[Avatar]

Joined: 19/10/2010 15:24:15
Messages: 272
Location: Princeton, ME
Offline

I gotta say I got my Firepod back from repair. I don't think they even looked at it! It still blinks red and blue and completely unusable. This is the second device I have had problems with. The first one was luckily under 30 days so returned at Guitar Center. But this one I registered and it was approved for an RA and it comes back the same completely useless part as before. It makes me think twice before buying any more Presonus hardware
(2)StudioLive 16.4.2, Phonic Helix 24, Teacc X3 MKII, StudioOne Pro 2, (2) Crown XTi 4000, (2) Crown XTi 2000, (2) Crown XTi 1000, (4) JBL JRX 125, (4) JBL JRX 118S, (4) JBL JRX 112m, (2) JBL JRX 115, EV ELX115P mains, EV EXP 118P subs, iMac 27 i5, Mac Book Pro, Dell Precision M6300, OS X 10.7.2, Windows 7 64
Texas Willie
Presonoid
[Avatar]

Joined: 28/07/2010 19:59:14
Messages: 1199
Location: Vancouver, Washington
Offline

Well, if you are still having problems after sending it to Baton Rouge, then something may be wrong with your set up.

I have sent my FSM in to PreSonus, and followed it online through the complete process they went through repairing it and I say without equivocation they are the BEST customer service repair I have EVER encountered!

I was able to see when it arrived, when it went on the bench, what they found during the bench diagnosis, and what they did to repair it.

Then it went to Quality Control for testing, which it passed....Then I was able to see when they shipped it out and I received the unit back within 3 days. In addition to that, my warranty was renewed from the date of repair!

It just DOES NOT GET ANY BETTER than that!

I am sorry you are still having problems, but to blame PreSonus is just not reasonable based on my experience with them. There are any number of things that could be causing the problem.....A bad F/W cable, an incompatible (Non-Texas Instrument) chipset, etc.

I would suggest you try installing on a system that has a Texas Instrument Firewire chipset and use a new F/W cable. I am not posting this to tick you off, just to relate my experience and hopefully help in some small way.

TW
PreSonus FireStudio Mobile x 2
Studio One Pro DAW v2.6
Yamaha DGX 220 Keyboard
Yamaha DTXplorer Drums
Akai MPK49 Midi Controller
M-Audio Axiom 25 Midi Controller
Boss BR-600 Digital Recorder
Guitar Rig Kontrol Pedal Board
Native Instruments Komplete 9
Epiphone Wildcat Semi-Hollow A/E
Breedlove Custom Studio A/E Guitar
Fender 12 String Acoustic/Electric
Fender American Stratocaster
TC-Helicon Harmony G
Sennheiser HD280 Pro Headphones

Windows 8 x64, SIIG PCIe DP Firewire 800 3 port card.

MacBook Pro OSX 10.6.8

AMD Phenom 9650 Quad Core 2.30 GHz; 8 GB Ram
Samsung 840 EVO 500Gb SSD-For O/S and Programs
Western Digital 1TB HDD x 2
Western Digital 1.5 TB HDD
[WWW]
skinfrakki
Presonic
[Avatar]

Joined: 19/10/2010 15:24:15
Messages: 272
Location: Princeton, ME
Offline

So the Firepod doesn't work with Mac devices? StudioLive works with it. This is not a computer hardware issue. I tried it with my laptop with a TI chipset and there are still issues. Even my Phonic Helix works better than this! If they can't make an audio interface that works with different firewire chipsets, they shouldn't sell firewire devices
(2)StudioLive 16.4.2, Phonic Helix 24, Teacc X3 MKII, StudioOne Pro 2, (2) Crown XTi 4000, (2) Crown XTi 2000, (2) Crown XTi 1000, (4) JBL JRX 125, (4) JBL JRX 118S, (4) JBL JRX 112m, (2) JBL JRX 115, EV ELX115P mains, EV EXP 118P subs, iMac 27 i5, Mac Book Pro, Dell Precision M6300, OS X 10.7.2, Windows 7 64
Texas Willie
Presonoid
[Avatar]

Joined: 28/07/2010 19:59:14
Messages: 1199
Location: Vancouver, Washington
Offline

Are saying you tried it with your Dell laptop and saying it has a Texas Instrument chipset?

AFAIK, no Dell laptop has a Texas Instrument chipset, unless you have an expansion card plugged into it. Maybe you are just confused?

Dell laptops use a RICOH chipset, which are NOTORIOUSLY unreliable!

TW

EDIT: I never said anything about a Mac not working with Firepod or Firestudio..........I know this much about Mac's_______! In other words nothing.

This message was edited 1 time. Last update was at 28/01/2012 22:55:43

PreSonus FireStudio Mobile x 2
Studio One Pro DAW v2.6
Yamaha DGX 220 Keyboard
Yamaha DTXplorer Drums
Akai MPK49 Midi Controller
M-Audio Axiom 25 Midi Controller
Boss BR-600 Digital Recorder
Guitar Rig Kontrol Pedal Board
Native Instruments Komplete 9
Epiphone Wildcat Semi-Hollow A/E
Breedlove Custom Studio A/E Guitar
Fender 12 String Acoustic/Electric
Fender American Stratocaster
TC-Helicon Harmony G
Sennheiser HD280 Pro Headphones

Windows 8 x64, SIIG PCIe DP Firewire 800 3 port card.

MacBook Pro OSX 10.6.8

AMD Phenom 9650 Quad Core 2.30 GHz; 8 GB Ram
Samsung 840 EVO 500Gb SSD-For O/S and Programs
Western Digital 1TB HDD x 2
Western Digital 1.5 TB HDD
[WWW]
skinfrakki
Presonic
[Avatar]

Joined: 19/10/2010 15:24:15
Messages: 272
Location: Princeton, ME
Offline

If you can show e under product description it specifying what chipset this device works with great! But from what I seen it's supposed to work with Mac. It doesn't work with an iMac 2009, Mac Book Pro 13, Mac Book Pro 15, or a Dell laptop. If this device is incompatible with this many chipsets it is not fully 1394 compliant
(2)StudioLive 16.4.2, Phonic Helix 24, Teacc X3 MKII, StudioOne Pro 2, (2) Crown XTi 4000, (2) Crown XTi 2000, (2) Crown XTi 1000, (4) JBL JRX 125, (4) JBL JRX 118S, (4) JBL JRX 112m, (2) JBL JRX 115, EV ELX115P mains, EV EXP 118P subs, iMac 27 i5, Mac Book Pro, Dell Precision M6300, OS X 10.7.2, Windows 7 64
skinfrakki
Presonic
[Avatar]

Joined: 19/10/2010 15:24:15
Messages: 272
Location: Princeton, ME
Offline

And if my Phonic Helix 24 firewire interface works, and the StudioLive 16.4.2 firewire interface works, it seems to me it's the device. I'm not buying a separate computer for this audio device
(2)StudioLive 16.4.2, Phonic Helix 24, Teacc X3 MKII, StudioOne Pro 2, (2) Crown XTi 4000, (2) Crown XTi 2000, (2) Crown XTi 1000, (4) JBL JRX 125, (4) JBL JRX 118S, (4) JBL JRX 112m, (2) JBL JRX 115, EV ELX115P mains, EV EXP 118P subs, iMac 27 i5, Mac Book Pro, Dell Precision M6300, OS X 10.7.2, Windows 7 64
skinfrakki
Presonic
[Avatar]

Joined: 19/10/2010 15:24:15
Messages: 272
Location: Princeton, ME
Offline

Same error message on any logs for any Mac -

1/28/12 1:41:17.000 PM kernel: FireWire (OHCI) Lucent ID 5901 built-in: 723 bus resets in last 3 minutes.
1/28/12 2:59:50.000 PM kernel: FireWire (OHCI) Lucent ID 5901 built-in: 2150 bus resets in last 3 minutes.

I plugged in my StudioLive and get none of these error messages
(2)StudioLive 16.4.2, Phonic Helix 24, Teacc X3 MKII, StudioOne Pro 2, (2) Crown XTi 4000, (2) Crown XTi 2000, (2) Crown XTi 1000, (4) JBL JRX 125, (4) JBL JRX 118S, (4) JBL JRX 112m, (2) JBL JRX 115, EV ELX115P mains, EV EXP 118P subs, iMac 27 i5, Mac Book Pro, Dell Precision M6300, OS X 10.7.2, Windows 7 64
Texas Willie
Presonoid
[Avatar]

Joined: 28/07/2010 19:59:14
Messages: 1199
Location: Vancouver, Washington
Offline

Where did you send your Firepod for service? Did you send this to PreSonus in Baton Rouge or somewhere else?

Having the experience I have had with PreSonus, I would be surprised by your result, if you did send it Baton Rouge.

Your Firewire (Lucent) would appear to be on the "Tested and Approved list", so we may be able to eliminate that. However, I would try a different (or new) F/W cable.....you just never know......

TW
PreSonus FireStudio Mobile x 2
Studio One Pro DAW v2.6
Yamaha DGX 220 Keyboard
Yamaha DTXplorer Drums
Akai MPK49 Midi Controller
M-Audio Axiom 25 Midi Controller
Boss BR-600 Digital Recorder
Guitar Rig Kontrol Pedal Board
Native Instruments Komplete 9
Epiphone Wildcat Semi-Hollow A/E
Breedlove Custom Studio A/E Guitar
Fender 12 String Acoustic/Electric
Fender American Stratocaster
TC-Helicon Harmony G
Sennheiser HD280 Pro Headphones

Windows 8 x64, SIIG PCIe DP Firewire 800 3 port card.

MacBook Pro OSX 10.6.8

AMD Phenom 9650 Quad Core 2.30 GHz; 8 GB Ram
Samsung 840 EVO 500Gb SSD-For O/S and Programs
Western Digital 1TB HDD x 2
Western Digital 1.5 TB HDD
[WWW]
skinfrakki
Presonic
[Avatar]

Joined: 19/10/2010 15:24:15
Messages: 272
Location: Princeton, ME
Offline

To Baton Rogue. This is the same symptom it did when customer service issued me an RA. I have tried 4 cables
(2)StudioLive 16.4.2, Phonic Helix 24, Teacc X3 MKII, StudioOne Pro 2, (2) Crown XTi 4000, (2) Crown XTi 2000, (2) Crown XTi 1000, (4) JBL JRX 125, (4) JBL JRX 118S, (4) JBL JRX 112m, (2) JBL JRX 115, EV ELX115P mains, EV EXP 118P subs, iMac 27 i5, Mac Book Pro, Dell Precision M6300, OS X 10.7.2, Windows 7 64
Texas Willie
Presonoid
[Avatar]

Joined: 28/07/2010 19:59:14
Messages: 1199
Location: Vancouver, Washington
Offline

skinfrakki wrote:To Baton Rogue. This is the same symptom it did when customer service issued me an RA. I have tried 4 cables


Alright then, if it were me, I would get on the phone first thing Monday morning and tell them they did not get it fixed! Let them know the hoops you have jumped through to make certain that the unit is STILL defective and not working.

Let me know what happens from there........Be patient on hold Monday

TW

PS, I would make sure to follow the progress through the ticket system.
PreSonus FireStudio Mobile x 2
Studio One Pro DAW v2.6
Yamaha DGX 220 Keyboard
Yamaha DTXplorer Drums
Akai MPK49 Midi Controller
M-Audio Axiom 25 Midi Controller
Boss BR-600 Digital Recorder
Guitar Rig Kontrol Pedal Board
Native Instruments Komplete 9
Epiphone Wildcat Semi-Hollow A/E
Breedlove Custom Studio A/E Guitar
Fender 12 String Acoustic/Electric
Fender American Stratocaster
TC-Helicon Harmony G
Sennheiser HD280 Pro Headphones

Windows 8 x64, SIIG PCIe DP Firewire 800 3 port card.

MacBook Pro OSX 10.6.8

AMD Phenom 9650 Quad Core 2.30 GHz; 8 GB Ram
Samsung 840 EVO 500Gb SSD-For O/S and Programs
Western Digital 1TB HDD x 2
Western Digital 1.5 TB HDD
[WWW]
skinfrakki
Presonic
[Avatar]

Joined: 19/10/2010 15:24:15
Messages: 272
Location: Princeton, ME
Offline

Patience my ass! I was on hold for and hour and 17 minutes! I own a StudioLive and this FIrepod and spent well over $2000 for this equipment! With that kind of money being spent they can afford to hire more customer service reps. I also don't like the fact that I put a piece of tape on the device, jammed it in the seal, marked it with RA1 and when I got it back the seal was intact. How can they fix the device without opening it?
(2)StudioLive 16.4.2, Phonic Helix 24, Teacc X3 MKII, StudioOne Pro 2, (2) Crown XTi 4000, (2) Crown XTi 2000, (2) Crown XTi 1000, (4) JBL JRX 125, (4) JBL JRX 118S, (4) JBL JRX 112m, (2) JBL JRX 115, EV ELX115P mains, EV EXP 118P subs, iMac 27 i5, Mac Book Pro, Dell Precision M6300, OS X 10.7.2, Windows 7 64
wesley
Presonic
[Avatar]

Joined: 17/04/2009 15:43:38
Messages: 217
Offline

If you were on hold for over an hour then something is wrong. Our phone system automatically routes calls to the receptionist after 15 minutes of hold time. Given that your FirePod is at least 5 years old (we discontinued FirePods in 2007), it's possible something's gone wrong with the chipset, however all repairs are sound tested before they are shipped back...that means it had to be connected to a computer before it left our factory.

Also, you don't mention having paid for a non-warranty repair (and most assuredly your FirePod is no longer under warranty) which means some one in Tech Support bro'd you out...especially considering that jamming tape or anything else into any opening in any of our products "officially" would void the warranty

Sometimes the repair fails during shipping. It happens. Please contact Tech Support again. Submit an email inquiry or give the boys a call. We'll get you sorted out.
Wesley Elianna Smith
Product Manager
skinfrakki
Presonic
[Avatar]

Joined: 19/10/2010 15:24:15
Messages: 272
Location: Princeton, ME
Offline

I bought this supposedly new, receipt says that, all software was sealed in the bag box was sealed. Everything. When I registered it it was registered as new. No out of pocket cost, I asked in advance. So none of that really applies. Hardware is not like milk and spoils after sitting for so long. And putting a piece of blue tape voiding the warranty means that someone doesn't like their workmanship checked. If putting a piece of tape over a connection piece in the device would void the warranty then maybe you should mention how fragile the device is that you can't put colored masking tape on it
(2)StudioLive 16.4.2, Phonic Helix 24, Teacc X3 MKII, StudioOne Pro 2, (2) Crown XTi 4000, (2) Crown XTi 2000, (2) Crown XTi 1000, (4) JBL JRX 125, (4) JBL JRX 118S, (4) JBL JRX 112m, (2) JBL JRX 115, EV ELX115P mains, EV EXP 118P subs, iMac 27 i5, Mac Book Pro, Dell Precision M6300, OS X 10.7.2, Windows 7 64
skinfrakki
Presonic
[Avatar]

Joined: 19/10/2010 15:24:15
Messages: 272
Location: Princeton, ME
Offline

And as far as e mailing I have sent 6 e mails, tried calling from 9:18 am to 1:37 pm without answer, and wrote on the tickets about this status. No one has looked at the tickets yet. Being in customer service at where I work, if a ticket wasn't looked at in the hour there would be some people pulled in the back office to explain themselves. I have two StudioLive 16.4.2, one of them When I purchased my first one there were issues and it had to be returned, the second one now has to have the Firewire ID switched from 1 and then back to 0 to work, and now this device. There hasn't been one product I have received that hasn't had issues. I've tried being supportive, I've tried passing your software and hardware as viable options, even had friends of mine buy your products due to my experience with it, but at this time, this is the last purchase I will make from Presonus. I don't delay in paying $2000 a mixer to you so I don't expect a big delay in service.
(2)StudioLive 16.4.2, Phonic Helix 24, Teacc X3 MKII, StudioOne Pro 2, (2) Crown XTi 4000, (2) Crown XTi 2000, (2) Crown XTi 1000, (4) JBL JRX 125, (4) JBL JRX 118S, (4) JBL JRX 112m, (2) JBL JRX 115, EV ELX115P mains, EV EXP 118P subs, iMac 27 i5, Mac Book Pro, Dell Precision M6300, OS X 10.7.2, Windows 7 64
skinfrakki
Presonic
[Avatar]

Joined: 19/10/2010 15:24:15
Messages: 272
Location: Princeton, ME
Offline

So over another hour and no one answering at support, pre sales, dealer support (because the company I bought it from is now getting involved), and the operator. There is no one answering anywhere. Again terrible support
(2)StudioLive 16.4.2, Phonic Helix 24, Teacc X3 MKII, StudioOne Pro 2, (2) Crown XTi 4000, (2) Crown XTi 2000, (2) Crown XTi 1000, (4) JBL JRX 125, (4) JBL JRX 118S, (4) JBL JRX 112m, (2) JBL JRX 115, EV ELX115P mains, EV EXP 118P subs, iMac 27 i5, Mac Book Pro, Dell Precision M6300, OS X 10.7.2, Windows 7 64
 
Forum Index » Pre-Sales Questions
Go to: